Passwords encrypted partitition during boot via ILO 3

Is it possible to type passwords for encrypted partitions during boot of SLES 11 via ILO 3 remote console. I put grub to non graphical and that appears in the remote ILO console also I can use the keyboard. Than the boot continues in graphical mode which is not echoed on the ILO console. Therefore I can’t tyoe the passwords remotely. Is there a way around this?? I tried to boot via serial console which I set up in grub but no echo anymore on the ILO console. How can I instruct sles to boot completely in terminal mode without doing the boot in a graphical way??

Yo need to modify the bootloader in YaST → System →
Bootloader and remove the splash=silent option. I’m assuming the system
is also set to boot to runlevel 3?

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-7-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thanx for your reply but that is not doing the trick, everything goes well in the start, i can see grub in the ILO console and interact, see the boot continue but then it goes to the graphical background on the server monitor and nothing moves anymore on the ILO console, I have to keep the whole boot in terminal mode in order to be able to interact with it via remote ILO console.

Ok, then set the splash to no via YaST → System /etc/sysconfig editor and search for splash, set the SPLASH option to no. You might also need to run the command mkinitrd after exiting yast.

Nope that didn’t do the job either. I have to pipe console 1 to the ilo3 console. So first make console 1 go through a com port which is internally via ilo3 assigned to the ilo3 console. Than remotely connect to ilo3 over ssh and start the vsp (virtual serial port) and the sles console should pop up. It works to the point that grub is ended after that nothing is showed in the ilo3 console anymore and I’m not able to type the luks passphrases. In the old days with LILO we made the console pipe to a com port so we could work via a terminal this must be possible in grub as well.

OK I set everything up and is working but the problem is with SuSE, how can I boot SLES in console mode so without any graphical make-up, do I mis a switch in the configsys editor in yast?? I can’t use the vsp or textcons of hp ilo3.

Do not forget to set “nomodeset” in grub by doing so sles boots completely in textmode and no problem with ILO3.

Problem solved, HP iLO needs the advanced license so you can start the textcons inside iLO only the vsp doesn’t do the job. In fact there is a whole howto to set iLO up with remote booting of SLES, Problem solved.