Private Registry image pulling fails

Hi ,

I have deployed Rancher 2.2 and i am using private registry (Harbor). I am trying to build a RKE cluster via rancher UI. But the images are not getting pulled on the cluster nodes. It says the below:

*Error response from daemon: pull access denied , repository does not exist or may require 'docker login`

But i have that particular repository in use and also i am able to pull those images manually from the respective nodes accessing the same repository. It fails only through the UI. Also I have set the harbor registry in Rancher’s global settings and still fails. Kindly assist.

Thanks & Regards,

someone kindly help.

Same here.
I suspect that the reachability of the registry from the nodes is the critical factor. Even if pingable my money is on the fact that Harbor registry can be on port 443 and not 5000 I think that’s what is giving Rancher nodes pause for connectivity. Not sure of the path to resolution other than maybe running rancher with a private repo on startup. Guidance welcome as well to resolve this and may bump over to slack to see who’s done what.

please paste the results of the below command:
docker info

Hi Dinesh,

Thanks for you response. Please find below the output

Containers: 5
Running: 1
Paused: 0
Stopped: 4
Images: 2
Server Version: 18.09.2
Storage Driver: overlay2
Backing Filesystem: xfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: bb71b10fd8f58240ca47fbb579b9d1028eea7c84
runc version: 2b18fe1d885ee5083ef9f0838fee39b62d653e30
init version: fec3683
Security Options:
Profile: default
Kernel Version: 3.10.0-693.17.1.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 15.51GiB
Name: X.X.X.lan
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false

No Proxy: localhost,x.x.x.x,x.x.x.x.56,,192.X.X.X,192.X.x.x,x.x.x.x.11,x.x.x.x.19,x.x.x.x.14,x.x.x.x.20,x.x.x.x.13,x.x.x.x.25,x.x.x.x.27,x.x.x.x.23,x.x.x.x.15,x.x.x.x.39,x.x.x.x.40,x.x.x.x.41,x.x.x.x.42,x.x.x.x.43,x.x.x.x.44,x.x.x.x.45,x.x.x.x.46,x.x.x.x.47,x.x.x.x.48,x.x.x.x.49,x.x.x.x.50,x.x.x.x.51,x.x.x.11,x.x.x.19,x.x.x.14,x.x.x.20,x.x.x.13,x.x.x.25,x.x.x.27,x.x.x.23,x.x.x.15,,,dockersrv02,x.x.x.10,,ihthbreg,x.x.x.50,x.x.x.x.16,x.x.x.x.110,x.x.x.x.7,x.x.x.x.12,x.x.x.x.22,x.x.x.x.17,x.x.x.x.26,x.x.x.x.8,x.x.x.x.24,x.x.x.x.29,x.x.x.x.28,x.x.x.x.33,x.x.x.7,x.x.x.12,x.x.x.22,x.x.x.17,x.x.x.26,x.x.x.8,x.x.x.24,x.x.x.29,x.x.x.28,x.x.x.12,,x.x.x.x.50,x.x.x.x.52,x.x.x.x.54,x.x.x.x.55,x.x.x.x.57,x.x.x.x.58,x.x.x.x.59

Experimental: false
Insecure Registries:
Live Restore Enabled: false
Product License: Community Engine

Thanks & Regards,

Have you included ‘private_registries’ within your rke cluster.yml. Also if it still does not work, try configuring a different port for the docker registry.