Problems connecting docker-machine to rancherOS

I just had RancherOS installed to a KVM machine. Had to setup a password to upload cloud-config.yml and all, but it went fine. My cloud-config looks like this:

hostname: rancher-01
  - ssh-rsa ...
    tls: true
        dhcp: false
        mtu: 1500

So far, so good. Then installed docker-machine on my local machine and tried to add my new docker vm to it. Result? Nasty error:

Unable to query docker version: Cannot connect to the docker engine endpoint

Docs have it that “some errors” may happen at this step. Then further we go: tried this command:

docker-machine env rancher-01

And got myself this error:

Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: dial tcp getsockopt: connection refused

Following some internet advise, I tried running this:

docker-machine regenerate-certs rancher-01

Which led me to pinpoint where the problem came from:

Setting Docker configuration on the remote daemon
Error creating machine: Error running provisioning: Unable to verify the Docker daemon is listening: Maximum number of retries (10) exceeded

Now, am I missing something?

It seems docker: tls: true made things not work. Trying to figure out why … (help appreciated =])