Rancher 2.0 and Kubernetes/Helm Odoo Install

I’ve just installed a fresh Rancher 2.0.6 on an AWS t1.medium. Rancher is up and running fine. I try to install Odoo from the Helm catalog and I run into trouble. From “kubernetes deployment does not have minimum availability” for Postgres to Persistent Volume error, I’m getting stuck with the deployment. My resources aren’t tapped either. Does any one have a nice little Gist that I can follow to install Odoo on Kunernetes under Rancher?

I’ll hit the inter-googles in the meantime.

There’s obviously some config wizardry I’m missing here. Cheers, Dave

same problem…

Hey Dave,
I guess you’ve resolved your problem but, for future visitors:
This issue is not related to the helm chart itself.
If you’re willing to persist your data in PSQL as in Odoo (database data and Odoo filestore data) you must have Volumes and PV/PVCs, because that’s the way that k8s handles persistence.
To make a really fast start I recommend you Longhorn. Just check the docs and you’ll be able to persist the data in minutes.
First create a volume, then a PVC named ‘odoo-data’ in the same namespace as your workload (f.e. ‘odoo’) and then, in the values.yaml add to the persistence section the parameter existingClaim: ‘odoo-data’.
Longhorn also allows you to make replicas on several pods, make remote backups, have a clean dashboard and much more.