Rancher 2.x private default registry


#1

Hi, I have custom cluster in 2.1.1 (RKE HA) and configured a private registry:

private_registries:
- is_default: true
url: “myprivateregistry”
user: “myuser”

After 2.1.2 upgrade, trying to edit cluster gives:

%cruPrivateRegistry.defaultError%

I guess error msg in it self is a bug, but now it seems editing the cluster yaml does not work correctly.


#2

Hey @hwaastad

Having the same issue with Rancher 2.1.3, did you ever come across a fix?


#3

Nope. I had to reinstall my cluster but the problem still exists.
Maybe a trip to slack might help.

Edit, now I see you’ve already gotten an answer from @vincent. But still the issue exists.


#4

Ya it’s a weird one. Hopefully they’ll fix it in an upcoming release. Glad there is a fix that is easy enough to apply.

In case anyone else finds this post looking for an answer the fix is to add the following to the cluster.yaml

cruPrivateRegistry:
  defaultError: You must designate one private registry as the default

#5

What? That’s not a fix, that’s just the translation message that you’re supposed to see instead of %cruPrivateRegistry.defaultError%


#6

Sorry Vincent I thought that was what you wanted added to the yaml file to surpress that message. I need more coffee.


#7

Yep adding the
is_default: true
to the private_registry line makes it go away.