Rancher Agent force public/external IP

is there anyway to force rancher agent to register a node only using the public/external IP?
one or more of my nodes are on a separate network and cant communicate using InternalIP

I have tried setting --address & --internal-address in every combination.
Have also tried editing the node directly with kubectl edit node <node_name> and changing the address to ExternalIP however after saving it is changed back immediately.

Exact same problem here. I am shocked, nobody provided even a hint to this problem since 1.5 years.
I am stuck with this, but we need to have a forced IP address for our setup to work.

I can’t remember if I ever got this working.

I ended up changing to K3S. K3S has a --node-ip flag that works well

I’m facing this problem too, 2 years old issue without any workaround or solution!

1 Like

Hello,
maybe these posts are old and not so actual as it was at the question time, but as I noticed it now and have a solution for this, wanted to share it here.
So I’ve solved the issue by re-registering the node with these flags in the client token string sudo docker run -d --privileged --restart=unless-stopped --net=host -v …Long String and Token Here --node-name $EXT_IP --address $EXT_IP --internal-address $EXT_IP --worker