Rancher air-gapped HA Installation

If this is obvious question I apologise, but I have not been able to find any answer.

I am trying to perform HA installation of Rancher 2.0 and I am following official documentation on the subject (https://rancher.com/docs/rancher/v2.x/en/installation/ha-server-install-external-lb/).
The key thing is – I am running the installation in air-gapped environment. I have been able to setup private docker registry and verify that all required docker images are stored there, easily accessible for any node on which Rancher should be deployed.

I have tried adding “private registries” variable to configuration yml file and prefixing the default image name with my registry name, however this does not help at all – the RKE installation fails on attempt to download “rancher/rke-tools:v.X.X.XX” – the image that is available, but under “<private_registry>/rancher/rke-tools:v.X.X.XX”.

I think that as a workaround, I could have manually download all images required by RKE to all the nodes and tag them without my registry name, but that seems to be very ugly.

Is there any way of explicitly telling rke rancher installer to use private registry for all image pulls?

For anyone having the same issue: https://rancher.com/docs/rke/v0.1.x/en/config-options/system-images/
Simply adding that to rancher-cluster.yml works (ofc you need to modify image names).

This can be closed :slight_smile: