Rancher-compose not pushing updates to sidekick containers

I have a stack that looks like this:

        io.rancher.container.pull_image: always
        io.rancher.sidekicks: sidekick
    tty: true
    image: nginx
    stdin_open: true
        - sidekick

        io.rancher.container.pull_image: always
    tty: true
    image: my/image
    stdin_open: true
        - "/usr/share/nginx/html"

When I use rancher-compose up -d on this stack, everything works as expected. The sidekick container executes a command on startup which populates /usr/share/nginx/html, which is then shared to the primary container. The sidekick container’s content is served by the primary container when I start the stack.

My intended workflow for this stack is to modify the sidekick’s content, rebuild the image, push it to the hub, and then tell Rancher to pull a new copy of the sidekick’s image from the hub and restart the sidekick container. When I run rancher-compose up -p -d -u -c sidekick, I see the following output:

INFO[0000] [0/2] [sidekick]: Creating
INFO[0000] [0/2] [sidekick]: Created
INFO[0000] [0/2] [sidekick]: Starting
INFO[0000] [1/2] [sidekick]: Started

When I check the container from the UI, there is no change: the sidekick container is still from the old image, which I verified by looking in the container from the shell. The same happens when I run rancher-compose up -p -d -u -c without specifying a service. Lots of creating and starting, no actual pulling.

Is this a bug, or is this intentional behavior? Should I use different commands for my workflow?


I have the same issue

I\m having a similar issue, nonetheless even if I delete all the services (rancher-compose rm -f) and then rancher-create it is not getting the new files from the build…

I’m using the S3 build directory building from a local directory… When I change a file in the container (i.e. entrypoint.sh script that runs the container init) I cant get it to see the new file… any ideas? (Tried removing the s3 bucket to no avail, its as if rancher-compose isnt seeing a change and using some sort of cache… docker-compose works fine…it rebuilds the fcontainer when I change the file)…

Has anyone solved this? I’m having the same issue.