Rancher HA and Docker versions

Is it still a requirement that the hosts for running a Rancher HA setup must be on Docker 1.10.3 ?

Has anyone been able to get it work with Docker 1.11 or 1.12?

I have been battling an HA setup for several days now. My initial setup was using Docker 1.12.1 - and I thought it might be this resulting in failures for the end of the setup to complete.

We have now tried to back to a setup with Docker 1.10.3 - and get the same result.

We are stuck with the load-balancer-swarm only successfully starting on one of our 3 HA servers. Looking at the management stack, we can see that the containers for this service are being created, fail, deleted, created, … and this never seems to end.

The error:

"transitioningMessage": "500 Server Error: Internal Server Error (\"failed to create endpoint r-management_load-balancer-swarm_1 on network bridge: Bind for failed: port is already allocated\")",

Has anyone else had this error and managed to find a solution for it? I urgently need to get this setup completed.

We have now managed to get this to work. It turned out that the Docker daemon on 2 of the hosts (the ones that were failing) was starting up with parameters that were using the Docker Swarm port (2376) - which is why it was in use.

Changing the docker daemon startup allowed us to get the whole HA stack up and running successfully.

For anyone who’s interested, the docker-machine call that was used to create the servers had set the following service startup:

ExecStart=/usr/bin/docker daemon -H tcp:// -H unix:///var/run/docker.sock --storage-driver aufs --tlsverify --tlscacert /etc/docker/ca.pem --tlscert /etc/docker/server.pem --tlskey /etc/docker/server -key.pem --label provider=scaleway(C2S)

My question on which versions of Docker that are supported with Rancher HA still stands though :wink:

I’m running my HA servers on 1.11.2 without any issues AFAICT

OK. Good to know.

Any official word from Rancher on this?

I’ve been running docker v1.12.5 ever since it was released with no issues (at least none related to the version of docker). Rancher have always been a bit coy about which docker versions are supported or not. In the past they have tended to say 1.10.3, but TBH that is so out-of-date and lacking important features that it would be surprising if many folk would accept that as a constraint these days. Same was true for docker-compose for quite a while, but now that Rancher supports v2 it’s possible to use the latest versions (I’m on 1.9.0 which isn’t quite the latest but not far off for v2). Of course for those using docker swarm mode, there will likely soon be a call for v3 support and the new deploy section.

HA in 1.2+ is simpler and supports the same Docker versions as are supported for hosts. Stability and the absolute latest engine version are often at odds, so we tend to be conservative in what we say is supported for customers.


docker-compose v3 largely just removes things they don’t feel like implementing in swarm, so I don’t see that being a practical.

Hah, thanks for the link, I hadn’t spotted that before. So not coy at all, … I take that back :wink: