Rancher keeps removing imagePullSecrets from only one deployment

Hey so Weird things are happing in my rancher deployments. I have a deployment that needs to pull from a gitlab repo. I have in the secrets for repositories but username and passwords to use our gitlab repo. This has worked out very well for almost all our deployments, except one. When ever we update it’s version to a version that it has not been pulled before Rancher removes it’s imagePullSecrets and leaves the pods stuck in an unauthorized state until I got and manually reinsert the secret’s name into the yaml. Then it works for that version. But I update it again and it does it again and I have to again re-insert the secrets again.
I have tried cloning and trying it again. That didn’t work.
I have deleted it and recreated it from scratch in the UI. Still doesn’t work.
I found this issue that was fixed but now its happening to me on 2.5.7! https://github.com/rancher/rancher/issues/18408

Its really weird because I have updated the versions on other deployments and they haven’t had any problems yet…

Well Hope I can find a solution to this one! Any help is appreciated.