Rancher Swarm Env. with no internet acces


I try to setup swarm environment in rancher without internet access. I followed this information Launching Rancher Server with No Internet Access but I got a problem about rancher-agent try to download rancher/swarm-agent:v0.1.2. How can I handle this problem? Is there any variable for setting where to get a swarm-agent image like “CATTLE_AGENT_INSTANCE_IMAGE”?

Thanks in adv.

We are just about to try running a swarm environment, and have run into this very same issue. I looked at the startup log on the rancher server container, but didn’t spot any references to a swarm image. Here’s hoping it’s lurking in there somewhere anyway… :wink:

If not, any plans for adding such an environment setting?, as we can’t use it until there is…

Also, when there is, it would be nice to have the agent image name and version included in the release notes as per the cattle images…


I managed to get a bit further by “impersonating” the rancher/swarm image on the agent nodes from our private repo. More details on github:


@kaos Have you gotten any further? I might have a solution:

No not yet. I postponed any further laborations until 1.2 was released (so, It’s become time to look at it again now, yay! :slight_smile: )

Also, I got information from one of the rancher online meetups that you’d be able to specify a custom registry to use for all images, rather than overriding the image names directly, which will work fine for my use case, and the up-side of that is that is generic and will work for all things deployed, not just specific rancher services.