Swarm Environment missing on Rancher 1.5

This is my first attempt at using Rancher to manage my Docker swarm.

I have Docker version 1.13.1 running in swarm mode on Ubuntu 16.04.2 LTS and Rancher server:v1.5.1 running.

However, when I open up the Rancher UI at localhost:8080 and try to set up a Swarm environment, the only Environment Template I am presented with is “Cattle” – No option for Swarm.

I see nothing in the documentation that suggests I need to do any other setup. What do I need to do to get the Swarm Environment Template working?

@emrobi - can you go to your setting page and make sure that Rancher Certified Library is enabled. If not click on the button and make sure to Save.

Yes, it was checked, but I clicked “Save” anyway. Now my environment templates include Cattle, Kubernetes, Mesos, Swarm and Windows.

This should get me to the next step. Thanks.