Rancher unable to find vpc/subnets when adding host on AWS

I tried to install Rancher 1.6.10 on a public subnet in VPC in AWS. Everything went smoothly until I tried to add a host. It accepted the AWS key and secret key but failed to populate the VPN/subnet field. I tried to inspect the network requests in Google Chrome. I see a response containing all subnets under the VPC. However, for some reason, it is not able to show the list in the UI. I do not have a default subnet. Could that prevent Rancher from determining which subnet to select? Or does it show them as a list, allowing the user to select it?

use custom host rather going to amazon ec2 from the rancher UI. You can still add EC2 from the custom host section. You would need to install rancher-agent on every ec2 machine that you would prefer adding to rancher ENV. This can be achieved by supplying user_data script to EC2 instance. This approach will be needed in case if you want to dynamically scale kubernetes cluster on AWS by using auto scaling.


sudo curl https://releases.rancher.com/install-docker/1.12.sh | sh
sudo usermod -a -G docker ubuntu
sudo docker run --rm --privileged -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/rancher:/var/lib/rancher rancher/agent:v1.2.6 https://rancher-kubernetes.mediaiqdigital.com/v1/scripts/TOKEN

TOKEN you will get it in add-host ( custom ) section in rancher UI.

We have tested above with ubuntu ami-da05a4a0 available in us-east-1 region