Rancher with Akka and Scala : not working


I have an application developed in Scala with Akka. The purpose of the app is to call external services and SQL databases (using JDBC), do some processing, and return a parsed result, on a recurrent basis. The app uses akka cluster so that it can scale horizontally.

The application is dockerized and when we deployed it manually (with a simple docker run), the app works like a charm and processed ~2500 calls/second.

But when we deployed it with Rancher, the app doesn’t work, the SourceScheduler stop working and doesn’t tick evvery second. Also, the app uses more CPU resources, and way more RAM (1.3GB in production vs ~350MB on my machine)
The production app runs in a JRE-8 alpine-based Docker container.

I inspected the containers with or without Rancher, and the only difference I saw is :
Without Rancher :

 "Path": "bin/scala",
 "Args": [],

With Rancher :

"Path": "/.r/r",
"Args": [

What is the /.r/r script ? And can we remove it from conf ?

Any ideas ?
Still have the problem

It’s an entrypoint script that makes sure managed networking is setup, then runs your provided/the image’s entrypoint.

Rancher is just starting regular Docker containers, with minor option tweaks like this. It’s not making your application use 4x the memory, some difference in your app/config is.

Hi Baptiste,

we are successfully using Akka (Scala) on Docker with Rancher. I guess the problem is probably related to host name / network configuration.

Are you using Artery for remoting or TCP based remoting?

We’re using TCP based remoting.

But when I run it, on the same host, with the same docker image, the app runs fine.
It’s not in the app or its should doesn’t work on the same host without Rancher.