Re: SLES11 SP1 KVM guest hangs at install or shortly after boot

On 08/17/2011 05:46 AM, magic31 wrote:[color=blue]

Lear-OSY;2127349 Wrote:[color=green]

We are using a RHEL6.1 based virtualization environment but one of our
software vendors requires that we use SLES11 SP1 to meet their support
contract. The standard hypervisor we’re using is

We’ve installed over 100 virtual machines on our hosts, but when I try
to install a SLES11 SP1 guest, the installer hangs early on (near the
network configuration or at the Time Zone page in the GUI install). I’ve
managed somehow to build a couple via autoyast, but shortly after
booting, they hang again. I can’t see any reason, and all logfiles are

The host OS/kernel: RHEL6 R1 2.6.32-131.6.1.el6.x86_64
The guest OS/Kernel: SLES11 SP1

I’ve tried a hundred different settings for creating the virtual
appliance: small amounts of RAM with few CPUs, large amounts of RAM with
many CPUs, low storage, high storage, installing via http, via cdrom,
with or without autoyast.

I’m completely out of ideas.[/color]

Haven’t done too much with Red Hat’s KVM implementation… but some

I can’t tell from the kernel version, but are you installing the 32bit
version of SLES 11 and ifso, have you also tried installing the 64bit

Which virtual nic are you using for the guest?



The cirrus driver is hideous and often the cause (not saying it is in this
case). Try switching to the vga one instead and see if that fixes things or not
for you (I’m talking about the guest). Oh… and stick with 800x600 as well,
that helps.