Reloading coredns config or resolv.conf

Hi allm my nameservers got changed and rancher containers are not able to ping/curl anything anymore. When updating /etc/resolv.conf on host/node, I am able to ping/curl from host, but still not from rancher containers. Is there any command I need to run to reload dns service to update resolv.conf config?

$ kubectl get pods -o wide -n kube-system | grep coredns
coredns-799dffd9c4-jfpxb                  1/1     Running     0          166d   <none>           <none>
coredns-autoscaler-84766fbb4-xw8bp        1/1     Running     0          166d   <none>           <none>
rke-coredns-addon-deploy-job-fsb2l        0/1     Completed   0          166d   <none>           <none>

I tried to kubectl delete pods -n kube-system coredns-799dffd9c4-jfpxb
and it did re-create a new one, but still the same old resolv.conf config.
I have changed resolv.conf on all nodes, where does it keep picking up the old config from?

Apparently when I try to edit config map of coredns and add forward . save it and then delete pod by kubectl -n kube-system delete po -l k8s-app=kube-dns it gets deleted, recreated, but still the same old config is in place which confuses me as it should have worked.

I would really appreciate the help, thanks!

Did you ever figure this out? I’ve had the same problem.