ReplicaSet has timed out progressing

I tried to deploy a couple of workloads one from a private registry, and jasonwyatt/nginx-loadbalancer, however for some reason, none of them can deploy, and I’m faced with the following error message:
ReplicaSet “test-7b95788b4f” has timed out progressing.; Deployment does not have minimum availability.
When trying to view the logs, i’m getting a 400 returned:

WebSocket connection to ‘wss://xxx.yyy/k8s/clusters/c-whbjb/api/v1/namespaces/default/pods/test-7b95788b4f-7zdwk/log?container=test&tailLines=500&follow=true&timestamps=true&previous=false’ failed: Error during WebSocket handshake: Unexpected response code: 400

Any ideas how to deal with why my workloads cannot deploy, and why I’m not able to view the logs?
I’m using Rancher 2.3.3

After taking a look at the cluster logs, I see quite many of these:

Failed create pod sandbox: rpc error: code = Unknown desc = failed to set up sandbox container “4d4cb06441d7a6383e4051e02efcd920308495c93f81ec282875dcb3afe0a58a” network for pod “load-balancer-test-59b59b8db9-tp55t”: networkPlugin cni failed to set up pod “load-balancer-test-59b59b8db9-tp55t_default” network: stat /var/lib/calico/nodename: no such file or directory: check that the calico/node container is running and has mounted /var/lib/calico/

I tried reinstalling the nodes with centos instead of coreos, which seemed to do the trick.