SAPGUI throwing error to connect SAP instance running in VM

Hello Experts,

SUSE Linux 11 SP4 running under VM Workstation 15
DB: Oracle 121

I am new to SUSE Linux and I had a peculiar problem to connect from SAPGUI to instance running under VM.
I have installed SAP6 EHP8 under my laptop and installation completed successfully.
Also installed SAP GUI 7.60 on my laptop, but now the problem is I am unable to connect my SAP instance running under VM.
I have googled it and tried to fix it but not succeeded. Steps I followed are:

  1. I have added entries under Windows —host file .
  2. I am getting ping response with FQDN hostname.
  3. SUSE end - No firewall service is running, currently it is disabled state. Do I need to open anything here…??? (I am not network expert either)
  4. But when I tried to connect SAP GUI to SAP instance, it is saying partner not reached
  5. My sap instance is running absolutely without having any problem in SUSE VM.

Somewhere I am missing my network connection from Windows Desktop to VM–Linux.
Could anyone help me what are the steps I should follow or cross check.
I will share logs later this evening if any one can help on this.

this issue resolved by restarting network service using “rcnetwork restart” after validating all the above changes