Service "service-name" is out of sync with local configuration file

I’m using Rancher 1.2.2 with rancher-compose 0.12.1 on a Osx 10.11.6 with Docker for Mac 17.03.1

When from my local machine I run rancher-compose up it stuck on “Service xxxx is out of sync with local configuration file”

This is how my docker-compose file looks like:

    version: '2'
        build: ./webapp
          - "3000:3000"
          - /var/www/webapp/current/node_modules
          - PORT=3000
          - MONGO_URL=mongodb://
          - ROOT_URL=http://localhost
        build: ./api
          - "3001:3001"
          - /var/www/api/current/node_modules
          - PORT=3001
          - MONGO_URL=mongodb://

And this is the last lines from rancher-compose up output:

DEBU[0117] Launching action for webapp
DEBU[0117] Launching action for api
DEBU[0117] Finding service api
INFO[0117] [0/2] [api]: Starting
INFO[0117] [0/2] [webapp]: Starting
DEBU[0117] Finding service webapp
DEBU[0117] Found service api
DEBU[0117] Found service webapp
INFO[0117] Uploading build for webapp using provider S3
INFO[0117] Uploading build for api using provider S3
INFO[0189] Build for api available at https://********************
DEBU[0189] Comparing hashes for api: old: digest.ServiceHash{Service:"5bdcfb2651b104af5605361bdcf7598b96ca99f7", LaunchConfig:"85604a798b48cd6db1104c4ead08bfec2d117e4b", SecondaryLaunchConfigs:map[string]string{}} new: digest.ServiceHash{Service:"5bdcfb2651b104af5605361bdcf7598b96ca99f7", LaunchConfig:"3d7f4ef3330e4086f43d767f58b1068d800137a6", SecondaryLaunchConfigs:map[string]string(nil)}
WARN[0189] Service api is out of sync with local configuration file
INFO[0285] Build for webapp available at https://**********************
DEBU[0285] Comparing hashes for webapp: old: digest.ServiceHash{Service:"ba0cb9b5e6595f71a07ca5574a67d7df8e8a283d", LaunchConfig:"f9cd043d1cf89bf4942515b665c00b76e19a514e", SecondaryLaunchConfigs:map[string]string{}} new: digest.ServiceHash{Service:"ba0cb9b5e6595f71a07ca5574a67d7df8e8a283d", LaunchConfig:"bd525984367396726aa52f9d1c88d0105bcb664f", SecondaryLaunchConfigs:map[string]string(nil)}
WARN[0285] Service webapp is out of sync with local configuration file

Can anyone help? Thanks!

I’ve tried updating both RancherOS and Rancher to the latest version but the issue persist.

I’m now using rancher-cli to build service from S3, always the same message “… is out of sync with local configuration files”. Container stay at “Waiting: container starting [container:1i24]” and never activate.