SLES12 instance fails to boot

Hi everyone,

I would like to create a SLES12 instance in my SUSE Cloud 5 environment. I tried different ways, but wasn’t able to create a running instance.
My cloud has two compute nodes, one running on SLES11, the other one is running on SLES12. I disabled compute service on SLES11 node, so that nova has to start the VM on the SLES12 compute node, just to make sure the difference between the two hosts is not the cause.
I couldn’t get a converted raw image running, so I tried to install SLES12 manually on a VM with virt-manager. I uploaded the raw disk file to the cloud but the VM is in an endless reboot loop after starting it; I see the boot menu for a few seconds where I can edit grub menu etc., but then it fails to start and then reboots again.
So I tried to boot it manually with xl create on compute node. I took the config file from our Xen host where I created the VM manually (not in the cloud) and used it (with minor modifications) to boot that VM on my compute node, and it worked! Unfortunately, there are no log files on the compute node to be able to compare it with the failing VMs. :frowning:
Is there any way to configure the creation process in nova boot or the image itself to get it working in the cloud?
I would really appreciate any help!

Best regards,

If you can, you should use KVM, as its codebase is better maintained than the openstack-nova-libvirt-xen path.

If that is not possible, using the official channels to file a support request would be the way to go.

bmwiedemann is right, although if you wish to debug further yourself, it might help to check /var/log/nova. However if it boots to grub successfully then this sounds more like an issue with your SLES12 image. I’d recommend trying one from Studio, e.g.

Thank you both for your responses.
I have filed a service request and we’ll see where we get.
We are using Xen in our company, so that would be the preferred way to got, but I’ve started to test with KVM.
I’ll update this thread if I have any new information.

For all of you interested in this issue, I’d like to update this thread.
My question has been answered, I had opened a Service Request and there will be a fix, soon.
The problem was the combination of Xen as hypervisor and btrfs as file system. Nova seems to choose the wrong bootloader and then fails to boot as I described. If you move the image’s boot partition to a ext3/4 file system, then the selected bootloader works fine.
Just a note on KVM: I can confirm that this also works without modifying the image’s boot partition. As a side effect it was quite nice to see some features of Cloud I had not seen before, e.g. the instance’s console log in the Horizon UI.