Starting open-iscsi service in rancher logs error

#1

I’m testing Prometheus, with a cTor Storage Class with OpenEBS, in a Rancher 2.1 Cluster (1 node) with RancherOS running in Hyper-v. The cStor volume is not mounting, and the pod is launching a event:

Unable to mount volumes for pod "prometheus-server-595746cc5-7xrmt_prometheus(46f03eb4-630f-11e9-b3e5-00155daf3d1f)": timeout expired 
waiting for volumes to attach or mount for pod "prometheus"/"prometheus-server-595746cc5-7xrmt". list of unmounted volumes=[storage-volume]. list of 
unattached volumes=[config-volume storage-volume prometheus-server-token-2w8ng]	a minute ago

I’m thinking that this is related with the output from command:

sudo ros s up open-iscsi

That is:

[rancher@kub-master ~]$ sudo ros s up open-iscsi
ERRO[0002] non-200 http response: 404
ERRO[0002] Failed to load rancher.docker.engine=(docker-18.09.5-ce): non-200 
http response: 404
INFO[0002] Project [os]: Starting project
INFO[0002] [0/21] [open-iscsi]: Starting
INFO[0092] [1/21] [open-iscsi]: Started
INFO[0092] Project [os]: Project started

So, the question is…the ERRO[0002] is important? where is documented how can i fix that?

I can’t find how to fix that, and I tried:

  • Reinstalling the open-iscsi service.
  • As i’m unsure if the container cannot mount the volume because this error, i tried recreating the Pool, the Storage class, etc, and the error appears again.
Add open-iscsi support on rancher
#2

i was trying openebs and experiencing the same issue, but getting a different error message. i tried a number of things and got different errors. i was finally able to mount an openebs pv with this, https://github.com/rancher/os/issues/2435#issuecomment-411262366

#3

I did not have a similar problem, please provide more information if possible so that I can reproduce.
Or you can refer to my way: