Support socks proxy in Rancher Agent

In my case we having services running in different places, some on public cloud like AWS and some on private clouds, we want use a single Rancher server to manage all our services by creating separate environments in Rancher. The issue is for the private cloud which we don’t have full control and all our out-going connections must go through the provided proxies, they provide http(s), ftp(s), socks proxy, etc. The issue is rancher agent talks in both http and websocket and the http(s) proxy we have doesn’t support websocket and there is no way we can change the proxy, but with socks proxy this should not be a problem. Actually I have engineered a solution to make rancher agent talks to the socks proxy indirectly and it worked (thank god) but if rancher agent can support socks proxy directly it would a lot easier and simpler. So I wonder if anyone else has the same issue and how it is solved if modifying the http(s) proxy is not an option. And if this is not that less common, perhaps I should create an issue (new feature) on github?

You can always create the issue in Github to see if there are other users who need it. If enough users also desire this, we can look into prioritizing it.