SuSE 11sp2 Xen and VmPlayer


Running Suse11sp2 with Xen for various Windows and Suse VMs.

I am trying to run VmPlayer 5 on the Suse Xen server to enable me to run a FreeBSD Application/Appliance.

If I boot the server into plain Suse the VmPlayer application loads and I can run my FreeBSD application with no issues. If I then boot the server into Xen and then try to load the VmPlayer I get the following errors in /tmp/vmware-root/vmware-modconfig-7275.log
Building module with command " /usr/bin/make -j8 -C /tmp/modconfig-1bzOse/vmmon-only auto-build HEADER_DIR=/lib/modules/3.0.13-0.27-xen/build/include CC=/usr/bin/gcc IS_GCC_3=no"
Failed to build vmmon. Failed to execute the build command.

Any help would be great.

Most other virtualization solutions will not work on Xen because Xen is
literally a different kernel. It works a lot like the stock Linux kernel,
but at a low level it is different. Chances are good that, unless Xen’s
code is integrated into the mainline kernel (so that you do not boot back
and forth between kernels, kind of like KVM works now as that is part of
the main kernel) this will never work.

Good luck.

mmmh, Ok, thanks. What about creating a Suse VM and then loading VmPlayer and running the application. That would be a vm in a vm … or is that not a good idea?

You could potentially do this with a fully-virtualized (vs
paravirtualized) VM, and the reasons to not do it are (afaik) centered
around performance. Paravirtualization gives you great performance, but
requires a modified kernel (paravirt VMs under Xen use a modified kernel,
or drivers that make this performance possible) but a fully-virtualized VM
is what we’re used to from the old days of VMware where everything was
emulated by software (thus the poor performance of VMware relative to Xen).

The benefit of full virtualization is that it doesn’t require kernel
modifications, so it is required for OS’s that are proprietary and do not
have the technology to do paravirtualiztion, and this also means that
other low-level software (VMware Player in your case) would likely work
just fine, though now you have two layers of full virtualization for
whatever is running with VMware Player. Performance won’t be great, but
some applications do not need super performance so it may be good enough
for what you’re doing.

Out of curiosity, what is the end goal of this application, and what
application is it?

Good luck.

Thanks for the info. The application is called BoostEdge by a French company called Activnetworks. The application runs on a FreeBSD platform as a VM and operates in a reverse proxy mode. Essentially it takes HTTP/S traffic, compresses it and sends it to the users browser. The browser users gzip to automatically decompresses the data. It reduces the data payload by about 40%. This is an enormous saving on bandwidth especially where I have many sites on 64/128kbits circuits.


Ah… well this is good. Assuming there are not better products out
there, is there any reason you do not run FreeBSD fully virtualized on
your Xen server? As far as I know that should be fine since that’s the
point of full virtualization.

Good luck.

In case it isn’t clear, I mean directly as in without VMware Player and
another OS in the middle.

Good luck.

Hi again,

I would prefer to run the VM on Xen. I had some success when the VM was on an earlier version of FreeBSD.

The VmPlayer’s guest.vmdk file was converted to a .img format with the following command : qemu-img convert guest.vmdk -O raw guest.img.

Within Xen I create a new VM as Ubuntu (as FreeBSD is not listed). I set up the memory, disk, NIC etc and then start the VM. The VM starts to boot and then after a few seconds I get the following error:

Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address = 0x0
fault code = supervisor read instruction, page not present
instruction pointer = 0x8:0x0
stack pointer = 0x10:0xffffffff80e5ec10
frame pointer = 0x10:0xffffffff80e5ec80
code segment = base 0x0, limit 0xfffff, type 0x1b
= DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags = interrupt enabled, resume, IOPL = 0
current processors = 0 (swapper)
[thread pid 0 tid 100000]
stopped at 0: *** error reading from address ***
db >

If someone could solve this issue I would then use Xen.

Ah, so this is some kind of soft appliance from the vendor that you’re
just supposed to load and run, vs. something that you install yourself on
FreeBSD after installing FreeBSD yourself, right? That makes a bit of
sense, though I do not know for sure why the problem now if things worked
on an earlier version of FreeBSD. Do you know for sure that the VMware
disk file does not have any snapshots (if it’s just one file it probably
does not)? When you created the instance of the VM (to which you added
the disk (vmdk) file) did you choose Full Virtualization, I assume? Any
option of a CD/DVD that can install the appliance to a system (for
example, a blank Xen VM) instead of using the .vmdk file directly? I am
assuming you’ve verified that this vmdk file is valid (not a corrupt
download, etc.) already, perhaps by loading it somewhere else in VMware
Player or similar.

Seeing your older thread, which version of FreeBSD is this?

Good luck.

Yup, that is my thread. The .vmdk loads correctly with VmPlayer in Windoze and in SuSE. I also ran a md5sum on the image and all is good.

I will speak to the “Application” developers and see if they can do something for me.

Thanks for your interest and help.


John Gill wrote:

Yup, that is my thread. The .vmdk loads correctly with VmPlayer in
Windoze and in SuSE. I also ran a md5sum on the image and all is good.

I will speak to the “Application” developers and see if they can do
something for me.

Thanks for your interest and help.



Use virtualbox to convert the vm and than run it through qemu. That is
what I have been doing and it works great. I did the same with the filer
betas to run them in xen and have not looked back. Again running as fully
virtualized but it runs without any issues. Just a thought.