Unable to access ssh from a different network

Is there something special I need to do to allow this connection? is the network that Rancher is on, is where I’m coming from. I tried looking for a firewall, but didn’t see it (ufw, iptables, firewalld). Any ideas?

Is these two network routable? I did similar, it works for me. btw do you mean rancheros or rancher server?

Both networks are routable. Yes, RancherOS is what I’m using. I did notice last night that I was trying to access outside of the network that RancherOS is sitting on and I couldn’t get outside, FW rules are in place at the perimeter to allow this and all the IP info is set properly on the RancherOS server. I can ping the GW, just nothing outside. I believe this is the culprit and probably something quite obvious that I’m missing. I’ll have time to work on this over the weekend.

I’m having the same issue using RancherOS 0.4.3 installed on bare metal. I have had Debian on that server and it worked just fine. I also have 4 other boxes on the same network still using Debian and I can access the RancherOS box from them just fine as well as from other servers from a different network. But I still cannot access (neither pings nor TCP ports are reachable) it from my laptop using VPN.