Unable to delete Traefik Ingress controller and use Nginx ingress controller

I installed Nginx ingress controller and everything works fine except that if i deploy an application (Wordpress) i can run the application but when i go to cluster explorer and view the pods, i can see that Wordpress is running and the nginx ingress controller pods are also running but in the Wordpress namespace i see 2 pods running and 8 pods on pending.

I tried to disable traefik, but every time i do that i can no longer access Rancher on the domain name that i created.
below is the url i used to disable traefik:
curl -sfL https://get.k3s.io | sh -s - server --node-taint CriticalAddonsOnly=true:NoExecute --disable=traefik --disable=servicelb --tls-san 192.168.X.X
If i run it nothing works anymore. I only see 3 namespace and all the others are gone.

Below is the current situation. Everything is working except the pending pods if i use the url below:
curl -sfL https://get.k3s.io | sh -s - server --node-taint CriticalAddonsOnly=true:NoExecute --tls-san 192.168.x.x
traefik disabled in the k3s service
namespaces with error
error message of a pending pod

My cluster configuration is that i have the following:

  1. 1 external load balancer

  2. 1 external database

  3. 2 master nodes

  4. 3 worker nodes

  5. 3 storage nodes.

when i want to go to my Rancher domain, the domain name is connected to the IP address of the external load balancer. Proxying the domain name to the IP address of the external load balancer is done by the built in reverse proxy that is running on my NAS.

My goal is that i want a complete removal or disabling of traefik in my k3s cluster. I want to only use Nginx ingress controller in combination with a external Nginx load balancer.
I hope that doesn’t mean that i have to reinstall everything again.

I hope someone could help me in this.

Is there no one who can help me solve this problem?
I thought that because its a Rancher forum that there are Rancher staff members involving in the forum to help others to solve their problems, besides other more experience users of the product

this may seem like an obvious question but did you install an nginx ingress controller?
something like kubectl apply -f https://raw.githubusercontent.com/kubernetes/ingress-nginx/controller-0.32.0/deploy/static/provider/cloud/deploy.yaml
? ← pick whatever version works for you

i have it working with nginx and traffek disabled with no issues

yes i install the Nginx ingress controller with this command:

$ git clone https://github.com/nginxinc/kubernetes-ingress/

I still haven’t found a way to completely remove Traefik from my K3s cluster version 1.20.6