Unable to register one SLES11SP3 server to SMT server

I have one SLES11SP3 server that was recently installed which won’t register with our SMT server. I installed another SLES11SP3 server the other day and it’s registered to the SMT server, so I don’t think the SMT server is the source of the problem.
When I run clientSetup4SMT.sh https://hamstall01v.hamcoll.sa.edu.au/center/regsvc, it prompts to accept the certificate, then gives the following output (I’ve run bash with -x to get debugging in case that helped):
[INDENT]+ read -p 'Do you accept this certificate? [y/n] ’ YN
Do you accept this certificate? [y/n] y

  • ‘[’ y ‘!=’ Y -a y ‘!=’ y ‘]’
  • ISRES=0
  • ‘[’ -d /etc/ssl/certs/ ‘]’
  • /bin/cp /tmp/smt.crt.ItBUQU /etc/ssl/certs//registration-server.pem
  • /bin/chmod 0644 /etc/ssl/certs//registration-server.pem
  • ‘[’ ‘!’ -x /usr/bin/c_rehash ‘]’
  • /usr/bin/c_rehash /etc/ssl/certs/
  • ‘[’ -d /etc/zmd/trusted-certs/ ‘]’
    ++ mktemp /tmp/suseRegister.conf.XXXXXX
  • SRCTMP=/tmp/suseRegister.conf.Xncf9M
  • /bin/cat /etc/suseRegister.conf
  • /usr/bin/grep -v ‘^url’
  • grep -v ‘^register’
    ++ date +%F
  • /bin/cp /etc/suseRegister.conf /etc/suseRegister.conf-2014-06-24
  • echo url=https://hamstall01v.hamcoll.sa.edu.au/center/regsvc
  • ‘[’ -n ‘’ ‘]’
  • echo ‘register = command=register’
  • /bin/cat /tmp/suseRegister.conf.Xncf9M
  • /bin/rm /tmp/suseRegister.conf.Xncf9M
    ++ mktemp -d /tmp/smtsetup-XXXXXXXX
  • TMPDIR=/tmp/smtsetup-sqp0Q90d
    ++ echo https://hamstall01v.hamcoll.sa.edu.au/center/regsvc
    ++ awk -F/ ‘{print “https://” $3 “/repo/keys/”}’
  • KEYSURL=https://hamstall01v.hamcoll.sa.edu.au/repo/keys/
  • ‘[’ -z /tmp/smtsetup-sqp0Q90d ‘]’
  • /usr/bin/wget --quiet --mirror --no-parent --no-host-directories --directory-prefix /tmp/smtsetup-sqp0Q90d --cut-dirs 2 https://hamstall01v.hamcoll.sa.edu.au/repo/keys/
    ++ ls ‘/tmp/smtsetup-sqp0Q90d/*.key’
  • rm -rf /tmp/smtsetup-sqp0Q90d/
  • echo ‘Client setup finished.’
    Client setup finished.
  • ‘[’ -z ‘’ ‘]’
  • read -p 'Start the registration now? [y/n] ’ YN
    Start the registration now? [y/n] y
  • ‘[’ y ‘!=’ Y -a y ‘!=’ y ‘]’
  • echo ‘/usr/bin/suse_register -i -L /root/.suse_register.log’
    /usr/bin/suse_register -i -L /root/.suse_register.log
  • /usr/bin/suse_register -i -L /root/.suse_register.log
    All services have been refreshed.
    Repository ‘SUSE Linux Enterprise High Availability Extension 11 SP3’ is up to date.
    Repository ‘SUSE Linux Enterprise Server 11 SP3’ is up to date.
    All repositories have been refreshed.[/INDENT]

The script then hangs at that point and never completes so the update repos are never added.

I get the following in the apache error log on the SMT server:
[INDENT][Tue Jun 24 13:13:17 2014] [error] [client] File does not exist: /srv/www/htdocs/robots.txt[/INDENT]

Nothing shows up in /var/log/smt/smt-register.log

Here is last part of /root/.suse_register.log:
[INDENT]2014-06-24 13:25:09 SUSE::SRPrivate - [info] SEND DATA to URI: https://hamstall01v.hamcoll.sa.edu.au/center/regsvc?command=register&lang=en-US&version=1.0:
2014-06-24 13:25:09 SUSE::SRPrivate - [info] <?xml version="1.0" encoding="utf-8"?>eba88a2e15fc4a9299e2
2014-06-24 13:25:09 SUSE::SRPrivate - [info] CODE: 200 MESSAGE: OK
2014-06-24 13:25:09 SUSE::SRPrivate - [info] RECEIVED DATA:
2014-06-24 13:25:09 SUSE::SRPrivate - [info] HTTP/1.1 200 OK
2014-06-24 13:25:09 SUSE::SRPrivate - [info] Date: Tue, 24 Jun 2014 03:55:40 GMT
2014-06-24 13:25:09 SUSE::SRPrivate - [info] Server: Apache/2.2.12 (Linux/SUSE)
2014-06-24 13:25:09 SUSE::SRPrivate - [info] Transfer-Encoding: chunked
2014-06-24 13:25:09 SUSE::SRPrivate - [info] Content-Type: text/xml
2014-06-24 13:25:09 SUSE::SRPrivate - [info]
2014-06-24 13:25:09 SUSE::SRPrivate - [info]
2014-06-24 13:25:09 SUSE::SRPrivate - [info] <?xml version="1.0" encoding="UTF-8"?>
2014-06-24 13:25:09 SUSE::SRPrivate - [info] <param id=“cpu” description="" command=“hwinfo --cpu”

<param i

d=“isdn” description="" command=“hwinfo --isdn”>

I’ve let the registration run for an hour or so several times but it never completes! Any idea what might be the problem? The missing robots.txt perhaps?


Hi Ian,

I’m off-site right now, but to me it looks like suse_register was told to provide further info and is in the process of gathering it locally. Obviously, per your description, this step somehow hangs - can you see any subprocesses unter suse_register (you might want to check via “pstree” for a first glimpse) that might provide a clue as to where suse_register is currently looking?


If you register from the command line, you can create a log file;

suse_register -a regcode-sles=YourActivationCode -a email=YourEmailAddress -a moniker=YourHostname -L /root/suse_register.log

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-11-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hi Jens & Malcolm,
You are correct Jens, pstree shows it’s running hwinfo.
Running hwinfo manually shows it’s hanging at /dev/xvda. I suspect it’s actually trying to scan the next disk device which is a SAN LUN & multipathd is causing it to hang for some reason.
Perhaps a reboot would sort it out, but I can’t do that at the moment.
I had included (an excerpt from) the log file in my first post - that shows hwinfo in the last entry, so I guess that was trying to tell me that was the problem.

I’ve just run the registration from yast and unticked the “send hardware profile” option and the registration worked!

Thanks for your help,

Hi Ian,

good to see you got it resolved… at least the “why” (and got registration to work) :slight_smile: Thank you for your feedback!