Vsftpd always replies with internal IP address to PASV command

Hello, SLES 15SP4 & vsftpd 3.0.5-150400.3.6.1 (latest version available) here.
When a client issues the PASV command the server always replies with “227 Entering Passive Mode (internal IP address + port)” even if the client is connecting from the Internet.
Set the pasv_address option to a fixed public IP address is not an option because I do need to connect to this server both from internal LAN and from the Internet so I need flexibility.
According to the man page, the default value of pasv_address should be “(none - the address is taken from the incoming connected socket)”.
Does the vsftpd-3.0.5-150400.3.6.1.x86_64 package has a bug?