wrong digest for SLES12 timezone-2015a-0.4.1.x86_64.rpm

I tried to update a SLES12 host, when I got the following error message:

[QUOTE]Wrong Digest
The expected checksum of file /var/cache/zypp/packages/SUSE_Linux_Enterprise_Server_12_x86_64:SLES12-Updates/x86_64/timezone-2015a-0.4.1.x86_64.rpm
is 73bc9af0f00c9efb0293ad9b288b0f1b0959ef637ee16649115ce03a3aaadd14,
but the current checksum is ba22ed840b82521aa7078bfda10b1aa1f49ba751d02bc5d0e02aa3629782c16f.

The file has been changed by accident or by an attacker
since the repository creator signed it. Using it is a big risk
for the integrity and security of your system.

Use it anyway?[/QUOTE]

I downloaded the file in my browser to replace the damaged file, but it has the same SHA256 checksum and the MD5 checksum is as published on the download site. ( 5bd43e332edeff9329872cb80d86aafd ).

Has anyone seen the same?


Manfred Herteux

Maybe an incomplete mirror, try again in a few hours…

I got a few emails last evening from my SUSE Manager instance of some
repo sync issues, but it retried later on and came in fine.

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.36-38-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thanks! Now it works.


In short this was caused by a mixup of RPMs.
To eliminate problems with possibly broken mirrored versions of timezone-2015a-0.4.1.x86_64.rpm SUSE bumped the release and published
timezone-2015a-0.8.2.x86_64.rpm, which has been verified to mirror fine during the daily mirror last night.