Yast fails updates -- can't write to file

I am trying to apply updates to my system using Yast2. I get the following message:

I’ve gone to the file indicated and checked the ownership and it is root/root with read/write authority. And I can use kate to open it. I do not understand the problem so short of re-installing SLED 15, is there a fast fix for problems like this?

And believe me, re-isntallin SLED 15 is painful because of the UEFI Bios of this motherboard. Half the time when I have to reboot because of some kernel patch I can’t get it to start again without resorting to a recovery boot.

Likely fallout from Infrastructure issues on Friday, the Leap 15 repositories went south (https://status.opensuse.org/incidents/184), probably influenced the package hub repository state. I would guess that some/all of package hub (SLE backports) is likely rebuilding and it may take awhile for things to get re-published.

Any idea when they will have everything fixed, and what I will have to do to get things working correctly? I’m not going to be surprised if I have to re-install SLED 15. (Third time to try to post this…).

Not sure, I see the repos on OBS, if you try and force a refresh, does
that help;

zypper -vvv -f ref

I see this: https://lists.opensuse.org/opensuse-buildservice/2019-03/msg00040.html

You also might try removing PackageHub and then re-add via SUSEConnect.

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I had tried it several hours after your post and it failed. So I figured there were still problems. So I tried it again again 10 minutes ago and this time it ran without error. BTW “-f” is not recognized. Only vvv -ref .

I also tried Yast’s Online Update and this time it ran fine and installed several patches.