3rd party module is not loaded automatically by udev at boot

Hello SLES Gurus!

…this will probably be an easy question for some of you out there, but I’ve not been able to come-up with an answer with the best of my Google-Fu.

I’m trying to get the Fusion-io Loadable Kernel Module (LKM) ‘iomemory-vsl’ - essentially the driver for use with ioDrive solid state storage devices) to load automatically, at boot.

Since this is a proprietary module, I’ve set ‘allow_unsupported_modules 1’ in /etc/modprobe.d/unsupported-modules and I am able to load the module manually via modprobe -i iomemory-vsl so I know that the LKM is fine and the ‘allow_unsupported_modules 1’ is being honored (before this was set, I would have to pass the ‘–allow-unsupported’ option to modprobe, to manually load the LKM).

What else do I need to do, to get a “tainted” module to load automatically, at boot?


In YaST sysconfig editor and under kernel, add to the “modules loaded at
boot” variable, this will then rebuild your initrd and add the module.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 1 day 17:37, 3 users, load average: 0.04, 0.04, 0.07
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Arrandale