Adding Host to vSphere fails

Rancher Version 1.1.0-dev4

When im adding a host using the machine-driver for vSphere, the machine is created but gets immediately deleted after pulling the rancher/agent image.

The interesting log part:
`time=“2016-06-15T09:33:26Z” level=info msg=“Activating Machine” eventId=1ef5bc85-d16d-41b1-b0c6-db873e272021 resourceId=1ph46
time=“2016-06-15T09:33:26Z” level=info msg="Pulling rancher/agent:v1.0.1 image."
time=“2016-06-15T09:33:26Z” level=info msg=“starting cleanup…” machine name=host02
time=“2016-06-15T09:33:27Z” level=info msg=“cleanup successful” machine name=host02
time=“2016-06-15T09:33:27Z” level=error msg=“Error processing event” err=“Post Forbidden” eventId=1ef5bc85-d16d-41b1-b0c6-db873e272021 eventName=“physicalhost.bootstrap;handler=goMachineService” resourceId=1ph46

I tried the docker-machine command which rancher created, manually and the machine persists after this. I even tried to use docker-machine v0.7 and 0.8-rc1. None of them work.

Sidenote: Im behind a corporate proxy, but im passing the http_proxy/https_proxy variable to the docker engine :confused:

Maybe, some of the devs can help we. I would like to introduce Rancher in my company, but i cant until this isnt fixed :frowning:

Thanks in advance! :slight_smile:

Did you ever get this figured out? I’m having a similar issue getting started with Rancher and VMware. Mine won’t even get to the point where it starts to create the vm and I wonder if it’s because of the http_proxy. Maybe I have to set no_proxy somewhere first?

Also, where do you see those logs, because I’m getting nothing in /var/lib/cattle/logs when this fails.