Adding to SLE10 dvd2 says "Can not Provide / media.1 from:"

This is something that bothers me a while to SLED / S 10. I can not add the second dvd to repositories, I can with SLED 10, SLES 10 and SDK 10.
Every time I want to add that indicates the error: “Unknown Error: Can not Provide / media.1 from”
Some time ago I tried several things, but could not make it work …
For zypper command line for me says:

SLEDSP4:~ # zypper service-add  cifs://Serverfs/Server_repos/SUSE_10_SP4_SLED_i386_dvd2
3076 zmd
ZENworks Management Daemon is running.
WARNING: this command will not synchronize changes.
Use rug or yast2 for that.
Determining cifs://Serverfs/Server_repos/SUSE_10_SP4_SLED_i386_dvd2 source type...
.. not YUM
cifs://Serverfs/Server_repos/SUSE_10_SP4_SLED_i386_dvd2 is type YaST
Please insert media [File './media.1' not found on medium 'cifs://Serverfs/Server_repos/SUSE_10_SP4_SLED_i386_dvd2'
] # 1 and type 'y' to continue or 'n' to cancel the operation. [y/n]: n
Unknown Error: Can't provide /media.1 from cifs://Serverfs/Server_repos/SUSE_10_SP4_SLED_i386_dvd2

The resource exists and is public.
The media.1 folder does not exist, there is only media.2
The same does not happen in SLE ​​11, will be a bug that was fixed in 11 SLE?

Thanks for getting this far, and sorry for using a translate.goole.

AFAIK, zypper isn’t supported, use rug or yast to add the repository
and see what happens.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 14:42, 3 users, load average: 0.09, 0.11, 0.16
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Hello malcolmlewis
With yast shows the same error, seeing / var/log/YaST2/y2log ( walk I found that tells me which way to go …
With yast or zypper repositories adds fine if the dvd is the number one (dvd1).
Something I missed comment, is that the share is the. Iso mounted with “mount -loop”. But I’ve tried other URI formats (iso and local dir).

What I need to try, all content is copy the DVD to a directory and create my own repository.