Adobe acrobat file read error

Hello everyone,

Another problem occured. Now the Adobe Acrobat Reader. When I ran it
for the first time I just accepted the license and closed it. After
that, I can’t open any .pdf file or even the Acrobat reader Application.
When I try to do that, I get an error: A file read error has occured
(Error in GUI). How should I solve this? I’ve got SLED 11 SP1, GNOME
desktop.


PauliusC

PauliusC’s Profile: http://forums.novell.com/member.php?userid=116334
View this thread: http://forums.novell.com/showthread.php?t=444537

I’ve never heard of this error, but since no one else has offered a
solution yet…

I can’t find much information about this via Google. There’s a thread
about this on the openSUSE forums, but it’s in Russian and I can’t see
that they found a solution. ‘Google Translate’
(http://translate.google.com/translate?hl=en&sl=ru&tl=en&u=http%3A%2F%2Fforums.opensuse.org%2Fp-russian%2Fdhydh-dh-dh-dhun-dh-dh-dh%2F1054-1073-1097-1080-1081%2F454186-adobe-reader-access-sled11.html)

What version of Adobe Reader do you have?

Code:

$ rpm -qi acroread

You could try deleting all your Adobe Reader configuration

Code:

$ cd .adobe
$ rm -rf Acrobat


But I don’t know if that will help since you presumably did not have
any configuration to start with.

Can you open PDF files in Evince? (Right click on the pdf file and
select Open With > Evince)


mikewillis

mikewillis’s Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=444537

mikewillis;2136737 Wrote:[color=blue]

I’ve never heard of this error, but since no one else has offered a
solution yet…

I can’t find much information about this via Google. There’s a thread
about this on the openSUSE forums, but it’s in Russian and I can’t see
that they found a solution. ‘Google Translate’
(http://translate.google.com/translate?hl=en&sl=ru&tl=en&u=http%3A%2F%2Fforums.opensuse.org%2Fp-russian%2Fdhydh-dh-dh-dhun-dh-dh-dh%2F1054-1073-1097-1080-1081%2F454186-adobe-reader-access-sled11.html)

What version of Adobe Reader do you have?[color=green]

[/color][/color]
Code:
--------------------[color=blue][color=green]

$ rpm -qi acroread[/color][/color]
--------------------[color=blue][color=green]

[/color]

You could try deleting all your Adobe Reader configuration[color=green]

[/color][/color]
Code:
--------------------[color=blue][color=green]

$ cd .adobe[/color]
$ rm -rf Acrobat
[/color]
--------------------[color=blue][color=green]

[/color]
But I don’t know if that will help since you presumably did not have
any configuration to start with.

Can you open PDF files in Evince? (Right click on the pdf file and
select Open With > Evince)[/color]

Code:

rpm -qi acroread
Name : acroread Relocations: (not relocatable)
Version : 9.4.2 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Release : 0.2.1 Build Date: Tue 01 Mar 2011 15:26:59 GMT
Install Date: Mon 12 Sep 2011 09:43:34 BST Build Host: chopin
Group : Productivity/Publishing/PDF Source RPM: acroread-9.4.2-0.2.1.nosrc.rpm
Size : 149516275 License: Any commercial
Signature : RSA/8, Tue 01 Mar 2011 15:31:59 GMT, Key ID e3a5c360307e3d54
Packager : http://bugs.opensuse.org
URL : http://www.adobe.com/products/acrobat/readermain.html
Summary : Adobe Reader for PDF Files
Description :
Acroread is a well known PDF viewer.

Adobe Reader is often the only program able to process complicated PDF
files, such as PDF forms. However, there are many bugs where we cannot
do anything about because it is proprietary binary-only software.

Please consider whether it is possible to use free PDF readers like
okular, evince, xpdf, ghostview, … instead.

Authors:

Adobe Systems Incorporated
Distribution: SUSE Linux Enterprise 11

And yes, I can open my files with Evince, I’m doing that actually. The
only problem is that it doesn’t work on browser, so it’s quite a problem
w/o adobe.

Thanks


PauliusC

PauliusC’s Profile: http://forums.novell.com/member.php?userid=116334
View this thread: http://forums.novell.com/showthread.php?t=444537

PauliusC;2136776 Wrote:[color=blue][color=green]

[/color][/color]
Code:
--------------------[color=blue][color=green]

rpm -qi acroread[/color]
Name : acroread Relocations: (not relocatable)
Version : 9.4.2 Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Release : 0.2.1 Build Date: Tue 01 Mar 2011 15:26:59 GMT
[/color]
--------------------[color=blue][color=green]

[/color]
[/color]
Well that’s the newest version, so that’s good.

Did you try deleting your config? I don’t know if it will solve the
problem but it’s easy to try.

PauliusC;2136776 Wrote:[color=blue]

And yes, I can open my files with Evince, I’m doing that actually. The
only problem is that it doesn’t work on browser, so it’s quite a problem
w/o adobe.
[/color]

You can make Firefox open PDF files in Evince instead of using the
Adobe Acrobat plugin. It’s what I do, I prefer it to the Adobe Reader
plugin. If you go in to Firefox preferences, click on the Applications
tab then search for PDF you should be able to select an alternative
application to use. If you want to select Evince you need to browse and
select /usr/bin/evince. (I think that’s right but I don’t have a SLED
machine to hand right now.)


mikewillis

mikewillis’s Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=444537

mikewillis;2137054 Wrote:[color=blue]

Well that’s the newest version, so that’s good.

Did you try deleting your config? I don’t know if it will solve the
problem but it’s easy to try.

You can make Firefox open PDF files in Evince instead of using the
Adobe Acrobat plugin. It’s what I do, I prefer it to the Adobe Reader
plugin. If you go in to Firefox preferences, click on the Applications
tab then search for PDF you should be able to select an alternative
application to use. If you want to select Evince you need to browse and
select /usr/bin/evince. (I think that’s right but I don’t have a SLED
machine to hand right now.)[/color]

When I wrote those commands absolutely nothing happened (except from
directory being changed).

Thanks for tip with Evince, I didn’t know, where to look for it. I’ve
set it up. Still, would like to repair Adobe.


PauliusC

PauliusC’s Profile: http://forums.novell.com/member.php?userid=116334
View this thread: http://forums.novell.com/showthread.php?t=444537

PauliusC;2137059 Wrote:[color=blue]

When I wrote those commands absolutely nothing happened (except from
directory being changed).
[/color]

The rm command should have deleted the directory called Acrobat. It
won’t have produced any output though. Typically command produce no
output if they are successful, only in the event of an error.

Did you try running Adobe Reader again afterwards?


mikewillis

mikewillis’s Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=444537

mikewillis;2137125 Wrote:[color=blue]

The rm command should have deleted the directory called Acrobat. It
won’t have produced any output though. Typically command produce no
output if they are successful, only in the event of an error.

Did you try running Adobe Reader again afterwards?[/color]

Wow, it actually works somehow. Thanks a lot :slight_smile:


PauliusC

PauliusC’s Profile: http://forums.novell.com/member.php?userid=116334
View this thread: http://forums.novell.com/showthread.php?t=444537

Excellent! Adobe Reader tends to be seen as the only and only PDF
viewer, but I highly recommend Evince. It’s generally lighter than Adobe
Reader and it starts up much quicker. Evince can’t handle PDF forms
though and sometimes people manage to construct PDFs in such a way that
only Adobe Reader can render them properly, so it’s worth having Adobe
Reader around just in case. I can’t remember the last time I used it
though.

Your earlier comment about not knowing where to look for Evince does
remind me that Evince hides itself from the Application Browser by
default. This is something which people sometimes think is a bug but is
actually intentional. I’ve never been convinced by the reasoning of it
being hidden.
If you run this as root

Code:

$ sed -i ‘/NoDisplay/d’ /usr/share/applications/evince.desktop

then Evince will show up in the Application Browser.


mikewillis

mikewillis’s Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=444537