Another HA issue

Hi again !

Context :
I work for small non-profit organisation (15members), we don’t have and don’t want professionnal host providers but we need a mail and storage server. Alltogether we have 4 computers available with 4 private internet connection (private as not professionnal, so slow upload speed).

Rancher high availability looks like a perfect solution. So I set up my testing environment using virtualbox and two Debian8 VMs with Docker 17.03.2-ce.
I started Rancher v1.6.2 with external MariaDB container (latest) and exposed port 9345 for HA, on both VMs.

Questions :

Each Rancher instance works fine. In HA menu, I can see the good advertised address on each one but they don’t see each other. How do they reach each other ?
VMs can ping each other.
I can curl ip:8080/ping from both Rancher instances.
I tried virtualbox 's private network or bridged network with dnsmasq, same behaviour.
I tried using ip, hostname or interface in --advertise-address when launching Rancher, again same behaviour.

Here are my commands :

docker run --name db -e MYSQL_ROOT_PASSWORD=password -e MYSQL_DATABASE=cattle -e MYSQL_USER=cattle -e MYSQL_PASSWORD=cattle -d mariadb
docker run -d --link db --restart=unless-stopped -p 8080:8080 -p 9345:9345 rancher/server --db-host db --db-port 3306 --db-user cattle --db-pass cattle --db-name cattle --advertise-address

What am I missing ?