AutoYaST xml profile on suma4.x

I’m trying to provision new device by autoinstallation in AutoYaST XML profile with github SUSE/manager-build-profiles/AutoYaST on SUMA4.2,

I can boot bare-metal on KVN/QEMU from bios in init ramdisk, but shows no filesystem could mount root and kernel panic in VM console, can you please kindly help to solve this issue.? or another template for reference in detail?

Jason Yang

Hi Jason,

can you give me more informations?
What autoyast - profile you try to use (may post the github link?
What OS you try to install? SLES15SP4 ?


Hi Tino,

I can boot from installer, but got the system profile location can not be fournd or retieved while read control file in suma 4.2.
And lots of warning about this is not a legal xml file in rule.

Please kindly advise.

Best Regards
Jason Yang

Hi Jason,

to do an Installation with PXE you need follow thinks configure on SUMA:

  • DHCP with correct entry e.g. “nextserver” (I think its working allready)
  • An clone of the SUSE original channel (original SUSE Channel is possible but not recomended, if you want to administrate you patch level) Which one you want to use? How is you channel name?
  • an distribution for SLES15SP3 , GUI → System → autoinstallation → distribution (I think you have one)
  • the customized Autoyast Profile (this create for you an cobbler profile)

did you use the autoyast template in an exact copy?
You have to change some thinks like the addons section? with correkt SUMA domain name and you configure disto?

I think your error is may regarding your missing porile and autoyast file. So did you add your system, with the cobler command “cobbler system add …” ?
Remember, that this is an profile on github, not the final autoyast file for you client.
you have to generate it by using the “cobbler system add…” command

I explain it a little bit in the old post here:

Did you have done all these steps? If not which one is missing or unclear?

please show me follow output

cobbler profile list
spacecmd distribution_list


Hi Tino,
Thank you for your sharing, I ran your command and output as below.

Well, the key of our question is on the XML file by autoyast. Yes, I copied the exact clone XML to modify the add-on items and save, and load the profile before the installer show, so, I have no idea what is going on for now ?

Best Regards,
Jason Yang

Hi Jason,

its look like, you want to install without individual generated autoyast configs…

So it looks like, you have an network problem in the yast part. So did you configure a route, dns in the DHCP? can you enter into an console when autoyast failed an check network config ?

Hi Tino,
DHCP and DNS is good, they all are in suma server on the same subnet, however, I got other error here even I have configured the software channel in base, maybe you can help this.

Very thanks!
Jason Yang

can you provide me you autoyast file? may your addon links are incorrect. Be carefull with capital letters, all names are lowercase. You have to wrote the “description” in of the subchannels, not the names. So klick on the subchannel to view the description or entrer follow command for a better overview

spacecmd softwarechannel_listchildchannels sle-product-sles15-sp3-pool-86_64

a typical addon entry for a childchannel looks like this

        <ask_on_error config:type="boolean">true</ask_on_error>




second problem could be you software section in your autoyast, Thit it contains these one?

    <patterns config:type="list">
    <products config:type="list">

FYI, for base system from UI, I have no spacemd command.

Jason Yang

Jason Yang

Hi Jason,

I think here is a problem. First of all, you wrote “spacemd” but it must be “spacecmd”. It is the command line tool for the most actions you can done in the gui. (space - command)

So I think you have to configure your autoyast profile like the github.

If I see your software section. It looks different. So you have to correct it first.
Further how you can see, your addon section is different from my example.

So you can use all addons from the the github examble by just replacing

$distrotree with “sle-product-sles15-sp3-pool-x86_64” - (your basechannel) and
$redhat_management_server with “” (your SUMA IP, if you DNS is working use the hostname+domain is better)

I Think the misstake was, that you use the “sle_sap15-sp3-autoyast.xml” profile from Github, which is for SAP. You have to use the “sles15-sp3-autoyast.xml”

So please check the other layout and fill out the vars.

regards Tino

Hi Tino,
My apology for typo, here is the spacecmd in your request:

I’ll check and try it again, I appreciate your kind support.

Jason Yang

Well, I step forward after your guidance, however, I got the add-on module error messages now. Can you please advise what is next?

Jason Yang

Hi Tino,

Found the problem in the path and solved it, thank you for your guidance again,

Jason Yang

Hi Jason,

nice to hear, that it looks better now. So your Installation works fine now?
May you are a beginner with SUMA, you may find this explaniation usefull on youtube, its about content lifecycle. It is allready a good idea to make development, test - and production channels.

Kind regards