Brought to emerg. mode due to unsupported optional feature


Right after installing SLED 15 I tried to boot it and I get taken to emergency mode with the error:

PKCS#7 signature not signed with a trusted key
Couldn't mount %sbecause of SUSE-unsupported optional feature %s. Load module with allow-unsupported=1.EXT4-fs (sdb1): METADATA_CSUM

. Must admit my experience with SLED 15 hasn’t been too positive so far, frankly for a paid product it’s doing poorly compared to its free counterpart, openSUSE Leap, but please feel free to help me turn that around as I’d love to be proved wrong! By-the-way, I know the error message might make it sound like I tried to boot it using another distro’s bootloader and that said bootloader was trying to boot it with different options to that which it supports, but no I booted it via its own bootloader (UEFI), sled-secureboot. So how do I fix this error? Is it like a kernel option I add to its GRUB entry?

Thanks for your time,

No, just a little more restrictive for support so somethings are off
by default :wink:

Maybe check out the release notes for another gotchas?

Add the parameter to either module loading (via grub kernel options),
system wide via editing /etc/modprobe.d/10-unsupported-modules.conf or
adding your own say /etc/modprobe.d/20-ext4.conf;

options allow_unsupported=1

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-23-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!