Cannot access service remotely via mapped ports

I have posted this issue on Github (, but I didn’t know which was the most appropriate place, so, feel free to close / delete this on one or the other. I’m just very eager to figure out what’s going on with this issue, as I really, really want to convince my colleagues that this system will be what is perfect for managing our Docker infrastructure. This issue is currently a huge blocker on that though!

I’ve been attempting to set up a Rancher controlled Jenkins node, just a simple setup. I’ve created a Rancher server on a VPS from DigitalOcean, and then added my dedicated server as a host. I’ve ensured that the IP of the host in Rancher is the dedicated server’s public IP address (not the docker0 interface’s IP address which it seems to default to).

From there, I added my service. The following settings were used:

This all goes fine, I’m only trying to start right from the basics here after all. I hit start and it boots up fine. If I then go onto the service page, the only public IP address I can attempt to access is the host IP, which does not work via the port I mapped.

If I SSH onto the host and attempt to cURL the container IP with the original, exposed port defined by the image (in this case, 8080, not the 13001 I had chosen), then I can get a response. That is the only interface / IP I seem to be able to get a response on. No matter which interface / IP I use, I cannot get the port I mapped to work, and I cannot get access publicly as I would like to.

The only way I’ve been able to get around this is by setting the networking mode to “host” while setting up the service, but that still doesn’t do anything with the port I decide to map it to, and it just works on port 8080, which makes trying to launch multiple jenkins nodes on the same host impossible (which is the main reason I want to do this!)

Is there anything I can check? Anything I’m doing wrong?

Rancher: v0.31.0
Cattle: v0.73.0
User Interface: v0.39.0
Rancher Compose: beta/latest
Docker version 1.7.1, build 786b29d (on both the host, and the rancher UI VPS)
Both running on Ubuntu 14.04.

If you need more information, iptables, etc then feel free to ask.

I found the issue. I had UFW enabled. Two options from there, disable UFW, or change /etc/default/ufw so that:


Is set.