Cannot add new hosts to Environment (ERROR: [server] is not accessible)

I’ve been working the past couple days to get a containerized GitLab up and running. At first I ran into this problem, where–when I spun up any services with exposed ports from the Rancher catalogs–they would inexplicably be blocked from anywhere except the host machine running the container.

It seems like I “solved” the problem by simply disabling the physical firewall, though it still doesn’t explain why, using pure Docker, I could access the services just fine until I used Rancher to spin up the containers. But that’s just an aside. To wit:

I now cannot add new hosts; same problem as this user, except I’m not using any SSL certificates. I have noted a lot of errors encountered by using Docker 1.11.1, but those problems have all been associated with health checks of containers, not getting the host container to even run in the first place.

Any suggestions would be much appreciated!

I went and looked at your other post. Are you aware that the command you ran will only stop the firewall temporarily? It will come back on when the system is rebooted.

You might be hitting this issue regarding your Catalog issues? It’s fixed in our latest release v1.1.0-dev2

We are currently only supporting Docker 1.10.3 for Rancher.

Could you share your full logs of your agent?

It looks like deleting the state directory on the host machine fixed the issue (see the ticket). However, I am using Docker 1.11.1; what problems can I expect with that?