Can't add a host

Hiya all,

I`m new to Rancher so pardon the probably silly questions.

I have been looking at using the Rancher OS to play with containers as my the company I work for will be using Rancher as a container solution.

I have deployed a Rancher OS and I have configured it to listen on port 8080 as per the guide below.

this guides you through running the host and server on the same machine, when I come to add the host, I have tried both my public IP and my Private IP but the host never appears. On the command line when I run the generated it pulls from the rancher/agent successfully but the host never appears.

I have tried re-installing several times using different OS’s

can anyone please advise as to what happening here?


What’s in the logs from the agent container?

How would I access those logs?

I had to specify reachable ip address (private or public), not using localhost. Probably because agent running in docker may not access to itself?

Yes, localhost is always the container you’re currently in so it’s trying to reach the server as if it were inside the agent container, where it clearly isn’t.