Cannot Bring Cluster Online

SLES12 SP1 with HA extension. I have followed to get the cluster initially configured using yast. However, i can’t seem to make it past Synchronizing the Configuration Files with Csync2. When i run csync2 -xf, i always get 3 or 4 errors that i cant seem to resolve. So i have a few questions to see where my mistake is:

  1. when i click on cluster in yast, i get:

When i search for hawk in software management, hawk2 is installed. So do i need to uninstall hawk2 and install hawk?

  1. in communication channels - is the bind network address suppose to be an available network address or the ip of the server?

  2. security section is checked for both of the nodes. On the first node, i generated the authkey and then copied that key to the 2nd node.

  3. config csync2 section -

I clicked generate preshared keys on both the nodes.

5)conntrackd section - the doc i am following (linked above) says this needs a dedicated NIC that is NOT used for anything else. This server does not have an available nic to dedicate to this. Can we continue without a dedicated nic for conntrackd? Also, the group id, what should this be? I have each node with its own group id (node 1 has group id 1 and node 2 has group id 2). Should the group id be the same on both nodes?

  1. service section -

So when i run crm status:

So i have gotten it down to 1 error:

On the config node, i have regenerated the authkey then copied it to the unconfigured node. Run csync2 -xf and cant get past the 1 file marked as dirty. I have stopped and restarted the csync service

I got the cluster online now!! I still would like to know the answers to the following: