Cannot create cluster (download failed - connection reset by peer)

I have setup a new rancher cluster with 2.2.8 (previous version was working fine but we started from scratch instead of upgrading)
When we try to create a cluster (vsphere/custom) the rancherOS VM is generated but after that the logs indicate a download failure

The rancherOS server can access the internet and wget other pages so I’m not sure why it’s failing to download anything.

In term of firewalling, we haven’t touched anything. Could this be a temporary cloudfare failure ?

It’s talking to the Docker daemon and retrieve an image that is failing, it seems like a network interruption. Can you try manually pulling or does it consistently fail over a window of an hour?

Yes it fails over several hours. I’m in the process of building a private registry and will check if the issue stays.

Edit : my private registry is running but despite setting it in the cluster setup option, the node continues to try to download from (apprently a cloudfare protected URL with the same error message.
According to my firewall logs, there is a few Go of download then the connexion resets.

Not sure why the node is not using my private registry…

Second edit : look like it’s working fine with a private registry on port 443 but I still had logs on the node regarding the above mentionned ip.
Also I discovered that one of our admin set up a 10mbps bandwidth limit on the internet side of the network I was using. It’s possible that’s was also part of the issue.

Well, problem solved