Can't access KubeAPI port [6443] when rke up on AWS! :(

Hi guys,

I’m going through Adrian Goins’ video, How Long Does Rancher Really Take? and I’m having the following error when I attempt to ‘rke up’:

FATA[0014] [network] Can’t access KubeAPI port [6443] on Control Plane host

Have any of you had this error and, if so, can you advise me how to resolve it?

Many thanks,


I am also currently stuck with the exact issue. Security is allowed all.

I’ve found the solution on github:

Basically use the option



rke up --disable-port-check