Failed to bring up Control Plane [what version works?]

I see a few people with the same issues creating custom clusters. Someone said they fixed the problem with firewall ports, someone else fixed it with certbot. Is there a version of Rancher I can go to that doesn’t have this issue? – I installed Rancher 2 beta on a different node a month back and didn’t have this issue. I tried today a few different times with the same issue so I know it’s not a fluke.

[controlPlane] Failed to bring up Control Plane: Failed to verify healthcheck: Failed to check https://localhost:6443/healthz for service [kube-apiserver] on host []: Get https://localhost:6443/healthz: dial tcp getsockopt: connection refused



1 Like

As it turns out, I did quite a few different things and the issue is now resolved. I have not figured out which of these was the ultimate solution, but I’m pretty sure it was DNS.

  • I removed IPv6
  • I turned off Firewalld
  • I ensured that I’m locked on Kubernetes 1.10.1-0 (it looked like that is all the further Rancher supported)

It still did not function until I changed the /etc/hosts.conf to order hosts,bind
in my environment something has registered and I think that was screwing things up without this setting.