Catalog stacks coming through as unhealthy with no useful messaging

I’ve recently set up to run RancherOS on my network to use GitLab’s CI runner stack (community:gitlab-multi-runner). However, adding this stack just tells me that it’s “Unhealthy” in the UI, with no useful feedback, and nothing I can find online has even given me a direction to look in.

I’ve tried setting up all kinds of services and regular Docker images using the UI and the CLI, but nothing I’ve tried has been anything but “Unhealthy”. I’ve tried following the tutorials in the docs amongst other things, and tried looking through the FAQs but haven’t found anything remotely close to helping me solve this problem.

Can anyone help point me in the right direction, or help clarify something I might have missed?

I think my RancherOS is 1.3.0, it’s reporting Rancher version as 1.6.12

$ uname -a
Linux rancher 4.9.80-rancher #1 SMP Tue Mar 27 02:21:37 UTC 2018 x86_64 GNU/Linux
$ docker -v
Docker version 17.09.1-ce, build 19e2cf6
$ system-docker -v
Docker version 17.06-ros3, build fa7c1dad