Changing Host Registration URL

Hi everyone,

I’m encountering with Rancher UI. I can’t access my local server after I configured the DNS in the Admin panel.
Is there a way to change via SSH, in a conf file, by any chance? And if so, how to do it?

Thanks in advance, guys.

The image you are showing isn’t displaying for me.

  1. What version of Rancher are you using?
  2. Changing the host registration URL shouldn’t have any affect on your Rancher UI. What do you mean by you can’t access your local server?

Thanks for your response !!
I use rancher
rancher : v0.56.0
Ui : v0.85.0
The problem is whenever i set the domain name i can’t reach ui of webrancher. And when i watch the log with$ docker logs [id_containers] , they are going crazy with : with the domain name but not the ip adress.
So is there an other way to change the domain name by my ip adress using the cmd.
I can send you the docker log if it helps

OK let me see if I can follow what you are explaining:
In the picture you attached you are showing the IP address of: - as your Rancher Web Interface.
Are you saying that you now have that IP address set with a DNS name?

I use the ip for my rancherOS (configured with Cloud-Config)
I thought about configuring a local DNS (url registration in the first screenshot) to access my rancher ui with this url : or

Now i notice a loop in the log of the master rancher container.

That page - in your first screenshot - is for setting the address (be it DNS or IP) that any hosts you are going to install Rancher-Agent on are going to “check back into”.

So are you trying to get “hosts” (running Rancher-Agent) to find their way to via a DNS address?


Are you just looking to be able to access your Rancher UI at via a DNS name?

That’s what i want to do.

OK so should be an internal IP on your home LAN correct?

So you just need to create a local DNS entry to point the DNS name you want to use to the IP.
Depending on your set-up this can be done a few different ways:

  • Some home routers can provide this type of entry to be added

  • I see from your screenshot you are on an Ubuntu box - so for that you could add an entry to the /etc/hosts file like:

  • For Windows PCs on the LAN the host file is located here: C:\Windows\System32\Drivers\etc\hosts

Hope that helps.

I found what was the problem !
My mistake didn’t have anything to do with the DNS, I thought the problem was the last modification i made on my server.

The mistake was the space left on my disk. It was full partition "/" 100%
I found this with the commande :
find / -type f -size +500000k -exec ls -lh {} \; | awk '{ print $9 ": " $5 }’

The file catlle-debug.log contains more than 1GB of data.

I rebooted the server and got access to my rancher interface.

Thanks for your help guys