Convoy-gluster activating

First time deploy here of convoy-gluster. The glusterfs containers are up and fine. The logs on the convoy-gluster containers just keep repeating this. Rebuilt the system with another set of VMs to test again and have the same issue. the convoy-gluster-storagepool container starts fine.

4/15/2016 2:30:20 PMWaiting for metadata
4/15/2016 2:30:20 PMtime=“2016-04-15T20:30:20Z” level=fatal msg="open /host/var/run/docker/execdriver/native: no such file or directory"
4/15/2016 2:31:48 PMWaiting for metadata
4/15/2016 2:31:49 PMtime=“2016-04-15T20:31:49Z” level=fatal msg="open /host/var/run/docker/execdriver/native: no such file or directory"
4/15/2016 2:33:49 PMWaiting for metadata
4/15/2016 2:33:51 PMtime=“2016-04-15T20:33:51Z” level=fatal msg="open /host/var/run/docker/execdriver/native: no such file or directory"
4/15/2016 3:12:39 PMWaiting for metadata
4/15/2016 3:12:41 PMtime=“2016-04-15T21:12:41Z” level=fatal msg="open /host/var/run/docker/execdriver/native: no such file or directory"
4/15/2016 3:13:06 PMWaiting for metadata
4/15/2016 3:13:06 PMtime=“2016-04-15T21:13:06Z” level=fatal msg=“open /host/var/run/docker/execdriver/native: no such file or directory”

Yup. It looks like we have an issue with convoy and docker 1.11. Are you using docker 1.11?

We are currently officially supporting Docker 1.10.3.

1 Like

Thank you, that is the issue.

Same error. Using Docker 1.11

1 Like

Same here. Using Docker 1.11

We have the same issue. Any ETA for Docker 1.11 support

Docker 1.11 support is to come in the next release of Rancher.

I had a try on rancherOS 0.5.0 that inludes Docker 1.11 but It look as if the issue is still there.

Not sure if this is related, but…

I had issues last week with Convoy/GlusterFS on a vSphere setup with Docker 1.11. I killed the whole setup and recreated it with Rancher 1.1.0 and boot2docker 1.11.2 yesterday. I created a GlusterFS stack with no issues. When I try to set up Convoy GlusterFS stack, it never completes. convoy-gluster-storagepool is stuck on initializing, and convoy-gluster is stuck on activating.

Any suggestions to get this working?

Here’s some log output if it helps…

From convoy-gluster_convoy-gluster-storagepool_1:
7/7/2016 8:43:22 AMWaiting for metadata 7/7/2016 8:43:22 AMtime="2016-07-07T13:43:22Z" level=info msg="Listening for health checks on" 7/7/2016 8:43:22 AMtime="2016-07-07T13:43:22Z" level=info msg="Socket file: /host/var/run/convoy-convoy-gluster.sock" 7/7/2016 8:43:23 AMtime="2016-07-07T13:43:23Z" level=info msg="Initializing event router" workerCount=10 7/7/2016 8:43:23 AMtime="2016-07-07T13:43:23Z" level=info msg="Connection established" 7/7/2016 8:43:28 AMtime="2016-07-07T13:43:28Z" level=debug msg="storagepool event [dcf3e939-2021-46bc-8dde-87880599770f 34e3f4aa-234f-4a6f-a436-e4498f1f4111 8e9dc6af-0232-4ea6-978f-0d56281abd8d]"

From convoy-gluster_convoy-gluster_1:
7/7/2016 8:43:32 AMWaiting for metadata 7/7/2016 8:43:32 AMtime="2016-07-07T13:43:32Z" level=fatal msg="open /host/var/run/docker/execdriver/native: no such file or directory"

This boot2docker tweak solved my issue, but it was a pain to track down.