Convoy NFS error: mount.nfs: access denied

Hi. I try to use Convoy NFS and get this error:

mount.nfs: access denied by server while mounting

What should i write to /etc/exports on NFS server?

Great. I solve “Access denied” trouble only setting “insecure” option in NFS server /etc/exports file because nfs-clients try to connect to illegal ports on NFS server.

But Convoy NFS still doesn’t start on all servers. It doesn’t start on main NFS server and on main Rancher server.

Doesn’t start as in there is a convoy-agent container that is failing to start or as in its not there but everything else looks fine?

If the container is there but failing to start and/or erroring out, can you share the logs for the convoy-agent container?

Containter in processing state. It throws no error in log but doesn’t get “Active” state.

You are right, it seems it needs the insecure flag. Is there a reason for that? I imagine there is no proper way to have it using a port below 1024 within the Docker and Rancher setup ?

It just does not sound right having an “insecure” flag enabled. (regardless what actually means in the context). Anyway, it should be on the documentation.

Also, someone tried with NFSv4?