Crowbar database creation is failing on Suse 12 SP2 Server

Hi,

I’m trying to setup Suse private cloud 7 environment on virtual platform by following the deployment guide https://www.suse.com/documentation/suse-openstack-cloud-7/book_cloud_deploy/data/book_cloud_deploy.html provided by Suse.

After executing the [B]“crowbarctl database create” [/B]it’s error with the following message.
crowbarctl database create --debug
RestClient.head “http://127.0.0.1/api/database/new”, “Accept”=>"/",
“Accept-Encoding”=>“gzip, deflate”, “User-Agent”=>“rest-client/2.0.0
(linux-gnu x86_64) ruby/2.1.2p95”

=> 404 NotFound | text/html 0 bytes

RestClient.post “http://127.0.0.1/api/database/new”,
“username&password”, “Accept”=>“application/vnd.crowbar.v2.0+json”,
“Accept-Encoding”=>“gzip, deflate”, “Content-Length”=>“17”,
“Content-Type”=>“application/x-www-form-urlencoded”,
“User-Agent”=>“rest-client/2.0.0 (linux-gnu x86_64) ruby/2.1.2p95”
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:790:in
rescue in transmit': Timed out reading data from server (RestClient::Exceptions::ReadTimeout) from /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:704:in transmit’
from
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:221:in
execute' from /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:52:in execute’
from
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/resource.rb:67:in
post' from /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/request/base.rb:69:in process’
from
/usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/command/database/create.rb:43:in
execute' from /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/app/database.rb:63:in create’
from
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in
run' from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in invoke_command’
from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in
dispatch' from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:115:in invoke’
from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:235:in
block in subcommand' from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in run’
from
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
invoke_command' from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in dispatch’
from
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/base.rb:440:in
start' from /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/util/runner.rb:50:in execute!’
from
/usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/bin/crowbarctl:34:in
<top (required)>' from /usr/bin/crowbarctl:23:in load’
from /usr/bin/crowbarctl:23:in `’

Any help to fix this issue would be appreciated.

Thank you,
NC

On 12/04/17 06:44, Nareshchodagam wrote:
[color=blue]

I’m trying to setup Suse private cloud 7 environment on virtual platform
by following the deployment guide’
https://www.suse.com/documentation/suse-openstack-cloud-7/book_cloud_deploy/data/book_cloud_deploy.html
(https://www.suse.com/documentation/suse-openstack-cloud-7/book_cloud_deploy/data/book_cloud_deploy.html)
provided by Suse.[color=green]

After executing the *“crowbarctl database create” it’s error with[/color]
the following message.[color=green]
crowbarctl database create --debug
RestClient.head “http://127.0.0.1/api/database/new”, “Accept”=>"
/*",
“Accept-Encoding”=>“gzip, deflate”, “User-Agent”=>“rest-client/2.0.0
(linux-gnu x86_64) ruby/2.1.2p95”

=> 404 NotFound | text/html 0 bytes

RestClient.post “http://127.0.0.1/api/database/new”,
“username&password”, “Accept”=>“application/vnd.crowbar.v2.0+json”,
“Accept-Encoding”=>“gzip, deflate”, “Content-Length”=>“17”,
“Content-Type”=>“application/x-www-form-urlencoded”,
“User-Agent”=>“rest-client/2.0.0 (linux-gnu x86_64) ruby/2.1.2p95”
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:790:in[color=green]
rescue in transmit': Timed out reading data from server (RestClient::Exceptions::ReadTimeout) from [/color] /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:704:in[color=green] transmit’
from
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:221:in[color=green]
execute' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:52:in[color=green] execute’
from
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/resource.rb:67:in[color=green]
post' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/request/base.rb:69:in[color=green] process’
from
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/command/database/create.rb:43:in[color=green]
execute' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/app/database.rb:63:in[color=green] create’
from
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in
run' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in[color=green] invoke_command’
from[/color]
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in[color=green]
dispatch' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:115:in[color=green] invoke’
from[/color]
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:235:in[color=green]
block in subcommand' from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in run’
from
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in[color=green]
invoke_command' from[/color] /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in[color=green] dispatch’
from
/usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/base.rb:440:in
start' from [/color] /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/util/runner.rb:50:in[color=green] execute!’
from
[/color]
/usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/bin/crowbarctl:34:in[color=green]
<top (required)>'[/color] from /usr/bin/crowbarctl:23:in load’
from /usr/bin/crowbarctl:23:in `’

Any help to fix this issue would be appreciated.[/color]

How is the networking configured on your Administration Server? How have
you set up your Software Repositories?

HTH.

Simon Flood
SUSE Knowledge Partner

Make sure you have postgresql94-server installed and started postgresql.service before running “crowbarctl database create”.

Admin server is having one nic card and it’s configured with static ipaddress “192.168.124.10”( using default crowbar networks only) . coming to Software Repositories, I have configured SMT server locally and mirrored all the repositories from " www.updates.suse.com" by running the command " smt-mirror -L /var/log/smt/smt-mirrror.log".

Thank you,
NC

I have tried as per your suggestion ,but still crowbar database creation giving me the same error message.

Thank you,
NC

Is crowbar-init running?

systemctl start crowbar-init

[CODE]
● crowbar-init.service - Crowbar Init
Loaded: loaded (/usr/lib/systemd/system/crowbar-init.service; disabled; vendor preset: disabled)
Active: active (running) since Tue 2017-04-18 20:01:03 IST; 34min ago
Main PID: 3500 (puma)
Tasks: 12 (limit: 512)
CGroup: /system.slice/crowbar-init.service
├─3500 puma 2.16.0 (tcp://127.0.0.1:4567) [crowbar-init]
└─3506 puma: cluster worker 0: 3500 [crowbar-init]

Apr 18 20:01:33 susadmin sudo[3777]: crowbar : TTY=unknown ; PWD=/usr/shar…ce
Apr 18 20:01:33 susadmin sudo[3777]: pam_unix(sudo:session): session opened…0)
Apr 18 20:13:15 susadmin sudo[4881]: crowbar : TTY=unknown ; PWD=/usr/shar…t]
Apr 18 20:13:15 susadmin sudo[4881]: pam_unix(sudo:session): session opened…0)
Apr 18 20:13:17 susadmin sudo[5078]: crowbar : TTY=unknown ; PWD=/usr/shar…ce
Apr 18 20:13:17 susadmin sudo[5078]: pam_unix(sudo:session): session opened…0)
Apr 18 20:13:17 susadmin sudo[5098]: crowbar : TTY=unknown ; PWD=/usr/shar…ce
Apr 18 20:13:17 susadmin sudo[5098]: pam_unix(sudo:session): session opened…0)
Apr 18 20:13:17 susadmin sudo[5134]: crowbar : TTY=unknown ; PWD=/usr/shar…ce
Apr 18 20:13:17 susadmin sudo[5134]: pam_unix(sudo:session): session opened…0)
Hint: Some lines were ellipsized, use -l to show in full.[/CODE]

There’s another thing we have experienced while setting up the cloud: DNS. Make sure your admin server is resolvable, add its fqdn to /etc/hosts. If possible, add it to your DNS server, too, in one of our installations the entry in /etc/hosts was not enough.

"hostname -f " is giving the expected output, anyhow I have started fresh installation and this time “crowbarctl database create” executed successfully without any error.

Thank you,
NC