Default-http-backend missing

I am no longer getting a default backend - 404 response when a service does not exist. Instead I am getting (52) Empty reply from server. I also noticed the default-http-backend service and deployment no longer exist in the new rancher. Is there any documentation on these changes?

I also noticed the ConfigMaps tcp-services and udp-services are missing. However ingress-nginx is still installed.

I am using rancher v2.6.0. I am using a custom cluster.

I noticed the the args

- --tcp-services-configmap=$(POD_NAMESPACE)/tcp-services
- --udp-services-configmap=$(POD_NAMESPACE)/udp-services

are missing from the nginx-ingress-controller. Is that intentional?

Ok, I have verified that was the issue. I’m still curious why those arguments were removed.

I think it’s not on by default anymore you have to enable it. I breifly remember Adrian Goins mentioning it in a video.

1 Like