Editing label on a host doesn't save properly

I set a label incorrectly, so clicked the edit action on the host. I deleted the incorrect label, then added the new one, and clicked save. The the host appeared to have no labels.

I have not been able to reproduce. Any time I edit the labels (deleting old ones adding new ones), it shows up on my host.

  • When did you set the incorrect label? Was it when you added the host to Rancher server? Or did you add it in the edit screen?
  • Was this a custom host or one from a cloud provider?
  • How many labels did you have in total?
  • Can you provide the incorrect key value pair and what you corrected it to be?

Sorry for the list of questions, but since I can’t easily reproduce, I need more information. :slight_smile:

This is a host I created, using the Rancher UI on Openstack. The host creation is fine.

Ok, in the UI I added this label, and now it shows up in the UI on the host.


In my docker-compose.yml I added this:

    io.rancher.scheduler.affinity:host_label: cluster.type=bogus

Does this look correct?

I don’t get any errors when I try to start it, but it’s also not starting the container. I verified that I can pull the image on the target host. I’m not sure where to look to debug this.

Please, advise.

ok, I need to work on being patient. Rancher must have been busy cleaning up from my previous failed attempts. I had a couple of instances of the target containers spinning in the UI, even though I had requested a delete several times. After I made my last post, waited a about 20 minutes and then the old containers were cleaned up. Then I re-tried my setup and it worked. :smile:

FYI the forum software or your post had a bunch of extra newlines all over it and your displayed text wouldn’t have actually worked, so I cleaned it up. It sounds like you had the right docker-compose.yml though since it’s working now.